Project

General

Profile

Bug #793

compilation on fedora 23: some worrying "error messages"

Added by John Abbott over 2 years ago. Updated 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Makefile
Target version:
Start date:
02 Nov 2015
Due date:
% Done:

100%

Estimated time:
3.10 h
Spent time:

Description

Compilation on the new computer (with fedora 23, due for release tomorrow ?!!? according to Wikipedia) produced several worrying messages in TmpFactorDir saying Fatal error; compilation terminated However, compilation proceeds anyway!

History

#1 Updated by John Abbott over 2 years ago

I shall try to investigate this, but it may take a long time. The new computer seems to be quite fast (e.g. more than twice as fast as my old portable), but it takes ages to compile: compiling and linking one example took about 1 minute real time (about about 1 sec CPU time).

#2 Updated by John Abbott over 2 years ago

  • Status changed from New to In Progress
  • Assignee set to John Abbott

The new computer took 100mins to compile and run the examples. Just running the examples takes only 30secs.

#3 Updated by Anna Maria Bigatti over 2 years ago

John Abbott wrote:

The new computer took 100mins to compile and run the examples. Just running the examples takes only 30secs.

... get a new portable (remember: use or lose it ;-)
Jokes apart: I think we should not worry too much about a machine with no local disk (I guess that's where the problem is)

#4 Updated by John Abbott over 2 years ago

I'm recompiling (with full debugging), and the mysterious Fatal error messages have not reappeared; and anyway despite them, the first compilation completed, and the tests passed... very odd!

#5 Updated by John Abbott over 2 years ago

I'm compiling some other programs; compilation time varies from 2mins to almost 5mins. I'll ask the technical guy if this is normal. Actually I think it is the linking which is taking so long... I don't think we can do anything about this (except perhaps remove lots of functions from CoCoALib, which is hardly practical).

#6 Updated by John Abbott over 2 years ago

  • % Done changed from 0 to 10
  • Estimated time set to 3.10 h

The Fatal error messages appeared once again when I tried building CoCoALib from a new unpackaged tar file. The errors about about the file gmp.h not being found during the creation of the dependency files.

I configured using a non-installed version of GMP-6.1.0.

Anyway, the internal dependencies should be independent of where the CoCoA source tree is.

#7 Updated by John Abbott over 1 year ago

  • Status changed from In Progress to Closed
  • % Done changed from 10 to 100

I have not noticed this problem lately. It wouldn't surprise me to find that it is due to the "wobbly" remote file system.

Closing.

#8 Updated by John Abbott 2 months ago

  • Target version changed from CoCoALib-0.99999 to CoCoALib-0.99560

Also available in: Atom PDF